Capture One 10


Mac OS X 10.11 (El Capitan) and 10.12 (Sierra) Only

DOWNLOAD NOW
Capture One 10.1.2
DOWNLOAD NOW
Capture One 10.1.1
DOWNLOAD NOW
Capture One 10.0.2
DOWNLOAD NOW
Capture One 10.0.1.26
DOWNLOAD NOW
Capture One 10.0.0.193

Windows


firmware_new

WARNING: we strongly recommend caution and absorbing the Release Notes and our testing results before taking on a firmware update.



DOWNLOAD NOW
Credo FW 4.01.2
DOWNLOAD NOW
Credo 50 FW 2.02.2

Do you need an older firmware? Contact us to request an older version for you.

P series Firmware Updater

Download firmware updater for P 45, P 30, P 25, P 21 and P 20 digital backs for Mac or Windows

DOWNLOAD NOW
P Series Updater Mac
DOWNLOAD NOW
P Series Updater Win

Firmware Updater Read Me


manuals


leica


Why Downgrade?

Sometimes a downgrade is necessary depending on many factors such as Camera firmware updates or Operating System updates that can cause instability with the current version of Capture One you may be running. A downgrade can help solve issues that may be affecting you caused by a newer version of Capture One Pro. E-Mail us at tech@captureintegration.com if you need help finding which version will suit your needs.

Select the version you need below:

Capture One Pro Archive (Mac OS)


Capture One 9 – (Mac OS X 10.10-Yosemite / 10.11-El Capitan / 10.12-Sierra Only)


Capture One 8 – (Mac OS X 10.9-Mavericks / 10.10 or 10.11 Only)


DOWNLOAD NOW
Capture One 8.3.4
DOWNLOAD NOW
Capture One 8.3.3
DOWNLOAD NOW
Capture One 8.3.2
DOWNLOAD NOW
Capture One 8.3.1
DOWNLOAD NOW
Capture One 8.3.0
DOWNLOAD NOW
Capture One 8.2.2
DOWNLOAD NOW
Capture One 8.2.1
DOWNLOAD NOW
Capture One 8.2.0
DOWNLOAD NOW
Capture One 8.1.0
Download the Release Notes
DOWNLOAD NOW
Capture One 8.0.2
DOWNLOAD NOW
Capture One 8.0.1
DOWNLOAD NOW
Capture One 8.0.0

Capture One Pro 6 & Earlier

OS X 10.5.8, 10.6.8, 10.7.1 or later only

OS X 10.5.8, 10.6.8, 10.7.1 or later only

OS X 10.5.8, 10.6.8, 10.7.1 or later only

OS X 10.5.8, 10.6.8, 10.7.1 or later only

Read the release notes.

OS X 10.5.8, 10.6.8, 10.7.1 or later only

OS X 10.5.8, 10.6.8, 10.7.1 or later only

OS X 10.5.8, 10.6.8, 10.7.1 or later only

OS X 10.5.8, 10.6.8, 10.7.1 or later only

OS X 10.5.8, 10.6.8, 10.7.1 or later only

OS X 10.5.8, 10.6.6, or later only

OS X 10.5.8, 10.6.6, or later only

OS X 10.5.8, 10.6 or later only

OS X 10.5.8, 10.6.8, 10.7.1 or later only